우분투에서 git 설치시 dpkg: error processing package git-daemon-run 오류 해결법
우분투 15.04 이후 버전을 기준으로 apt-get으로 git을 설치하는 도중 다음과 같이 오류가 발생했습니다. 우분투 언어가 영문으로 되어 있는 경우 오류 내용이 다를 수 있습니다.



알아보니 우분투 15.04 버전 이후로 의존성 관련 내용이 바뀌어 발생하는 버그(?) 라고 합니다.
해결 방법으로는 지금까지 설치하려던 git을 깔끔하게 제거 후 apt 명령어로 재설치 하는 것입니다.

다음의 명령어를 차례대로 따라하는데, 관리자 권한이 필요하므로, root 계정 로그인 또는 sudo 명령어를 사용하시기 바랍니다.
# apt-get purge runit                                                                        
# apt-get purge git-all
# apt-get purge git
# apt-get autoremove
# apt update
# apt install git
cs




git-all로 설치하고 싶은 경우
git-all은 git뿐만 아니라 하위 패키지를 포함합니다. 위의 해결법으로는 git-all을 설치한것이 아닙니다.
다음의 방법으로도 해결 가능합니다.
# apt-get purge runit                                                                        
# apt-get purge git-all
# apt-get purge git
# apt-get autoremove
# apt update
# apt-get install git-daemon-sysvinit
# apt-get install git-all
cs


블로그 이미지

도로락

IT, 프로그래밍, 컴퓨터 활용 정보 등을 위한 블로그

댓글을 달아 주세요! 질문 환영합니다!