pip 설치시 오류. You are using pip version... 해결 방법
pip install 명령어로 파이썬 pymssql을 설치하려던 도중 다음과 같은 문제가 발생했습니다.



오류 내용을 보니 현재 pip 버전이 10.0.1 버전인데 18.0버전이 나왔으니 pip를 업그레이드 해야한다고 하는군요.
Command "c:\users\dololak\appdata\local\programs\python\python37-32\python.exe -u -c "import setuptools, tokenize;__file__='C:\\Users\\KIMDON~1\\AppData\\Local\\Temp\\pip-install-h40_7c7d\\pymssql\\setup.py';f=getattr(tokenize, 'open', open)(__file__);code=f.read().replace('\r\n', '\n');f.close();exec(compile(code, __file__, 'exec'))" install --record C:\Users\KIMDON~1\AppData\Local\Temp\pip-record-deyqyxt5\install-record.txt --single-version-externally-managed --compile" failed with error code 1 in C:\Users\KIMDON~1\AppData\Local\Temp\pip-install-h40_7c7d\pymssql\
You are using pip version 10.0.1, however version 18.0 is available.
You should consider upgrading via the 'python -m pip install --upgrade pip' command.


해결 방법은 너무나 단순합니다. 추천하는 명령어를 통해 pip를 업그레이드합니다.
python -m pip install --upgrade pip

pip 업그레이드에 성공했습니다. 이전에 설치하려고 했던 파이썬 모듈을 다시 pip로 설치하면 성공할 것입니다.





블로그 이미지

도로락

IT, 프로그래밍, 컴퓨터 활용 정보 등을 위한 블로그

댓글을 달아 주세요! 질문 환영합니다!