우분투 apt-get 망가진 고정 패키지가 있습니다 해결방법
apt-get 을 통해 패키지 설치시 다음과 같은 오류가 발생하는 경우가 있습니다.
망가진 고정 패키지가 있다며 해당 패키지에 대한 정보를 보여줍니다.
ubuntu@client:~$ sudo apt-get install vim
[sudo] password for ubuntu:
패키지 목록을 읽는 중입니다... 완료
의존성 트리를 만드는 중입니다       
상태 정보를 읽는 중입니다... 완료
몇몇 패키지를 설치할 수 없습니다. 요청한 상황이 불가능할 수도 있고,
불안정 배포판을 사용해서 일부 필요한 패키지를 아직 만들지 않았거나,
아직 Incoming에서 나오지 않은 경우일 수도 있습니다.
이 상황을 해결하는데 다음 정보가 도움이 될 수도 있습니다:
다음 패키지의 의존성이 맞지 않습니다:
vim : 의존: vim-common (= 2:7.4.1689-3ubuntu1) 하지만 2:7.4.1689-3ubuntu1.1 패키지를 설치할 것입니다
E: 문제를 바로잡을 수 없습니다. 망가진 고정 패키지가 있습니다.

여기서는 vim 패키지를 설치하는데 vim 패키지가 의존하는 vim-common이 설치가 제대로 되지 않았습니다. vim-common의 버전은 = 2:7.4.1689-3ubuntu1입니다.



이러한 경우 apt-get으로 직접 해당 의존패키지를 설치해줍니다.
이때 버전을 뒤에 붙여줍니다. 띄어쓰기를 없애서 붙여서 써줍니다.
sudo apt-get install vim-common=2:7.4.1689-3ubuntu1


-y 옵션을 주지 않은 경우 직접 y를 눌러 넘어갑니다.




해당 의존 패키지를 정상적으로 설치했으면 원래 설치하려 했던 패키지를 설치합니다.
sudo apt-get install vim


만약 여전히 오류가 난다면 다음과 같이 apt-get install 패키지.* 명령을 실행한 뒤에 다시 위와 같이 반복해 줍니다.

sudo apt-get install vim.*
블로그 이미지

도로락

IT, 프로그래밍, 컴퓨터 활용 정보 등을 위한 블로그

댓글을 달아 주세요! 질문 환영합니다!